Thank you for your interest in VASCO’s eID-compatible card readers. We have changed our name to OneSpan.

We are committed to being the one partner that you can turn to for all your authentication, mobile app security, fraud analysis and e-signature needs.

We discontinued the direct-to-consumer sale of VASCO card reader authenticators on May 30, 2018 but will continue to support the eID-compatible card readers previously sold on this site through the life of their warranties.

If you are still interested in purchasing an eID-compatible card reader, please contact one of the following vendors:


If you have further questions, please contact us or visit OneSpan.com.


Frequently Asked Questions - FAQ - DIGIPASS 905

How do I change my DIGIPASS when it is broken?

Type:
FAQ FAQ (# 990080)
Date Added:
5/07/2012 12:37:00

Question

How do I change my DIGIPASS when it is broken?

Answer

Complete the form on: https://shop.vasco.com/rma_form.aspx and we will notify you afterwards.

 

How to install the DIGIPASS 905 on Suse?

Type:
FAQ FAQ (# 990058)
Date Added:
26/04/2010 10:46:00

Question

How to install the DIGIPASS 905 on Suse?

Answer

In the standard installation of OpenSuse pcsc-lite, openct and opensc are automatically installed.
The only component that needs no be installed is pcsc-ccid? this can be done via the installation software Yast.
Check if all above mentionned components are installed. If not, please install them.

For all pre- OpenSuse version 11:

Adjust "/usr/lib/readers/ifd-ccid.bundle/Contents/Info.plist"  and add the following information:

  • VendorID (1a44)

  • ProductID (0001)

  • Description (e.g. "VASCO DP905").

 
If the pcscd daemon application is started, please stop it. This can be doen via the following commands:

   1. Enter "ps -A" and check the Process ID of pcscd.
   2. Enter "sudo kill "


Enter the following commands to check if the DIGIPASS 905 works correctly:

    * "sudo opensc-tool -a" 
      This shows the ATR of the card.

    * "sudo opensc-tool -s 00:A4:04:00:07:A0:00:00:00:04:80:02:00"
      This shows the MasterCard.


PS: Do not forget to install the Belgian e-ID software.

 

How to install the DIGIPASS 905 on Ubuntu?

Type:
FAQ FAQ (# 990057)
Date Added:
26/04/2010 10:08:00

Question

How to install the DIGIPASS 905 on Ubuntu?

Answer

First check if the DIGIPASS 905 is recognized by the system. This can be doen by enterign the command "lsusb". Int he list a device with ID 1a44:0001 should be present.

Install the following modules:

   1. pcscd (install: typ in terminal: "sudo apt-get install pcscd") 
   (1a. Verify that libccid is installed. If not enter the following command "sudo apt-get install libccid")
   2. opensc-tool (install: typ in terminal: "sudo apt-get install opensc")
   3. openct-tool (install: typ in terminal: "sudo apt-get install openct")

The following actions are only necessary when using pre- 9.10-versions:

Adjust the "/etc/libccid_Info.plist" and add the following information:

  • VendorID (1a44)

  • ProductID (0001) 

  • Description (e.g. "VASCO DP905").

Stop the pcscd daemon:
   1. Enter "ps -A" and check which Process ID the pcscd has.
   2. Enter "sudo kill "

Start the pcscd daemon (as superuser: "sudo pcscd") It's possible to add the paramter "-f" to let everything happen in foreground mode.

Open a terminal window to check if everything works correctly:

     - "sudo opensc-tool -a" 
        This shows the ATR of the card.

    - "sudo opensc-tool -s 00:A4:04:00:07:A0:00:00:00:04:80:02:00" 
       This shows the MasterCard.

PS: The EID software can be installed via "Add Software" in Ubuntu.

 

How can I check why my Card Reader is not working?

Type:
FAQ FAQ (# 990059)
Date Added:
26/04/2010 11:07:00

Question

How can I check why my Card Reader is not working?

Answer

Please go to http://dp.demo.vasco.com/SmartCardDiag.

If ntohing is shown, please install the latest version of Java Virtual Machine.

 

Can my DIGIPASS 905 be used for Terminal Services?

Type:
FAQ FAQ (# 990060)
Date Added:
26/04/2010 11:10:00

Question

Can my DIGIPASS 905 be used for Terminal Services?

Answer

This is possible indeed.

It is necessary that the driver is installed on both the local machine and the remote server (TSC or Citrix)

 

Can I use my DIGIPASS 905 for VAT-declarations?

Type:
FAQ FAQ (# 990061)
Date Added:
26/04/2010 11:18:00

Question

Can I use my DIGIPASS 905 for VAT-declarations?

Answer

This is possible.

Please have the FedICT software installed. Otherwise necessary drivers may not be found.

 

Where do I need to download drivers for VISTA/Windows 7?

Type:
FAQ FAQ (# 990062)
Date Added:
26/04/2010 11:18:00

Question

Where do I need to download drivers for VISTA/Windows 7?

Answer

You don't need to download any specific drivers for both operating systems.

The DIGIPASS 905 uses the standard CCID-driver, which is embedded in Windows.

 

Can I read a Kids-ID or a Foreign-ID with my DIGIPASS 905?

Type:
FAQ FAQ (# 990063)
Date Added:
26/04/2010 11:22:00

Question

Can I read a Kids-ID or a Foreign-ID with my DIGIPASS 905?

Answer

This is not VASCO-related issue. This needs to be asked if the software of the Belgian Government supports this kind of type.

 

Do I need administrative rights to install my DIGIPASS 905?

Type:
FAQ FAQ (# 990064)
Date Added:
26/04/2010 11:26:00

Question

Do I need administrative rights to install my DIGIPASS 905?

Answer

Yes, the DIGIPASS needs to install drivers. Without administrative rights, the installation of these drivers fails.

 

Why do I get installation of drivers failed, but I'm still able to read my eID-card?

Type:
FAQ FAQ (# 990065)
Date Added:
26/04/2010 11:28:00

Question

Why do I get installation of drivers failed, but I'm still able to read my eID-card?

Answer

During the installation of the DIGIPASS 905, two separate things are installed.

First of all the DIGIPASS 905 itself. This installs perfectly fine.

Secondly the eID-card itself and this is where the error-message comes from. No suitable driver for the eID-card itself can be installed.

 

How to install the DIGIPASS 905 on Mac OS X?

Type:
FAQ FAQ (# 990066)
Date Added:
26/04/2010 11:35:00

Question

How to install the DIGIPASS 905 on Mac OS X?

Answer

Go to https://www.vasco.com/products/two-factor-authenticators/hardware/card-readers/digipass-905.html and download and install the following:

  1. Dedicated VASCO CCID driver for MAC OS X
  2. DIGIPASS plug-in for eID Middleware for Mac OS
  3. DIGIPASS PCSC daemon solution (pcscd_autostart.pkg)
 

My DIGIPASS 905 is installed, but my eID-card is not read?

Type:
FAQ FAQ (# 990067)
Date Added:
26/04/2010 11:39:00

Question

My DIGIPASS 905 is installed, but my eID-card is not read?

Answer

  • Insert your card into the DIGIPASS 905 Card Reader.
  • Wait 10 seconds. 
  • First of all make sure that the FEDict Belgian eID-software is closed. Also check that there are no processes running in the background (e.g. beid35gui.exe when looking at the processes in the task manager). 
  • Now start the  FEDict Belgian eID-software. The data on your eID-card will be read correctly.

 

When I install the driver for my DIGIPASS 905, I receive the following error message: “The installation ended prematurely due to a fatal error”. How can I solve this?

Type:
FAQ FAQ (# 990068)
Date Added:
2/08/2010 10:31:00

Question

When I install the driver for my DIGIPASS 905, I receive the following error message: “The installation ended prematurely due to a fatal error”. How can I solve this?

Answer

When you try to install the driver found on the website on a Windows 7, you may receive the above error  The driver only needs to be installed on Windows XP SP2 or lower. All above versions of Windows use a standard driver provided by Microsoft.

 

More questions?

If you still require VASCO Support, please click here.